in.touch 2 App Authentication issue
Incident Report for
in.touch 2
Resolved
This incident has been resolved.
Posted
Oct
20
,
2025
-
20:17
EDT
Monitoring
The remediation for the security certificate issue has been successfully implemented and is now deployed to all affected environments.
While the ongoing AWS major outage may still impact stability, our team will continue to actively monitor the systems.
Posted
Oct
20
,
2025
-
16:24
EDT
Investigating
We are currently investigating this issue.
Posted
Oct
16
,
2025
-
15:09
EDT
This incident affected: Android App and iOS App.
×
Subscribe to Incident
Subscribe to updates for
in.touch 2 App Authentication issue
via . You'll receive .