in.touch 2 remote control degraded
Incident Report for
in.touch 2
Update
A fix has been deployed and we're monitoring remote connections.
Posted
Dec
27
,
2025
-
12:05
EST
Monitoring
An issue have been reported related to remote control by multiple users.
Posted
Dec
23
,
2025
-
12:03
EST
This incident affects: Cloud Services (Remote Control).
×
Subscribe to Incident
Subscribe to updates for
in.touch 2 remote control degraded
via . You'll receive .